Hatena::Grouplinux2

server_setting_memo このページをアンテナに追加 RSSフィード

2007-05-03 (Thursday)

[][]hotmail転送 hotmail転送 - server_setting_memo を含むブックマーク はてなブックマーク - hotmail転送 - server_setting_memo hotmail転送 - server_setting_memo のブックマークコメント

こちら(http://d.hatena.ne.jp/yu_ya/20070331/p1)で紹介されているhotmailの転送をしようと一日頑張ってたんですが、私の環境(FC5)だとできず。

  1. luaインストールは完了
  2. freepops-0.2.2-1.fc6.i386.rpmが依存関係にあるrltd(GNU_HASH)、つまりglibcインストールがうまくいかない
    • システムにはglibc-2.4が入ってる
$ rpm -qa | grep glibc
glibc-kernheaders-3.0-5.2
glibc-devel-2.4-11
glibc-common-2.4-11
glibc-2.4-11
glibc-headers-2.4-11

# rpm -Uvh glibc-2.5-10.fc6.i386.rpm 
error: Failed dependencies:
        glibc-common = 2.5-10.fc6 is needed by glibc-2.5-10.fc6.i386
        glibc > 2.4 conflicts with glibc-common-2.4-11.i386
        glibc = 2.4-11 is needed by (installed) glibc-headers-2.4-11.i386
        glibc = 2.4-11 is needed by (installed) glibc-devel-2.4-11.i386

# rpm -Uvh glibc-*
error: Failed dependencies:
        glibc = 2.4-11 is needed by (installed) glibc-headers-2.4-11.i386
        glibc = 2.4-11 is needed by (installed) glibc-devel-2.4-11.i386

    • 1つ目のエラーは消えたが、あと2つが消えない。
# rpm --test -e glibc-headers
error: Failed dependencies:
        glibc-headers is needed by (installed) glibc-devel-2.4-11.i386
        glibc-headers = 2.4-11 is needed by (installed) glibc-devel-2.4-11.i386
# rpm --test -e glibc-devel  
error: Failed dependencies:
        glibc-devel >= 2.2.90-12 is needed by (installed) gcc-4.1.1-51.fc5.i386
# rpm --test -e glibc-headers glibc-devel
error: Failed dependencies:
        glibc-devel >= 2.2.90-12 is needed by (installed) gcc-4.1.1-51.fc5.i386
# rpm --test -e gcc 
error: Failed dependencies:
        gcc = 4.1.1 is needed by (installed) libtool-1.5.22-2.3.i386
        gcc = 4.1.1-51.fc5 is needed by (installed) gcc-gfortran-4.1.1-51.fc5.i386
        gcc = 4.1.1-51.fc5 is needed by (installed) gcc-c++-4.1.1-51.fc5.i386
        gcc is needed by (installed) systemtap-0.5.10-1.fc5.i386

うわあああああああ


    1. ちなみに、glibc-2.5をインストールするにはものすごい数のパッケージと依存関係にあるらしい。さすが根底をなすことだけはある。
# rpm --test -e glibc-2.4 > test.log 2>&1
error: Failed dependencies:
        ld-linux.so.2 is needed by (installed) numactl-0.6.4-1.27.i386
        ld-linux.so.2 is needed by (installed) libwvstreams-4.2.1-2.i386
        ld-linux.so.2 is needed by (installed) wvdial-1.54.0-5.2.2.i386
.
.
snip
.
.

        /sbin/ldconfig is needed by (installed) libglade-java-2.12.5-1.fc5.i386
        /sbin/ldconfig is needed by (installed) libvte-java-0.12.1-5.fc5.i386
        /sbin/ldconfig is needed by (installed) isdn4k-utils-3.2-41.1.fc5.i386
        /sbin/ldconfig is needed by (installed) gstreamer-0.10.4-1.i386

ちなみに

# wc -l test.log 
5908 test_e_glibc2.4.log

こんなことにw


なんとかならないかとyum upgradeしてみたものの、解決しなかった上に何故かsambaが使用不可に;;

この話は、こちらhttp://linux2.g.hatena.ne.jp/bbs/1


FC6入れるしかないのか。面倒だなあ

tani@kinol.co.jptani@kinol.co.jp2007/12/21 09:57yum.conf に以下を追加記述して上手くゆきました。
[updates-released]
name=Fedora Core $releasever - $basearch - Released Updates
baseurl=http://ftp.riken.jp/Linux/fedora/core/updates/$releasever/$basearch/
gpgcheck=1

pneumasterpneumaster2008/08/14 11:43あわわ.
遅くなってしまいごめんなさい.そしてありがとうございます.